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Introduction

Welcome to the RealAudio Player 3.0 beta by Progressive Networks. The RealAudio system
is the premier real-time audio delivery system for the Internet.

Using the RealAudio Player 3.0 beta, you can listen to thousands of hours of live and pre-
recorded clips, including sporting events, live radio stations, news, music, and lectures. In
addition, the RealAudio Player 3.0 beta includes several different RealAudio Player
components and provides access to a customized Timecast World Wide Web site.

For more information, refer to our web site http://www.realaudio.com

See Also:

New Features

RealAudio Players

Using the RealAudio Player 3.0 beta
Troubleshooting




New Features

New features in the RealAudio Player 3.0 beta:

¢ New Codecs - Eight new encoding algorithms, including several for connections faster than 28.8
Kbps connections. In addition, there are now multiple codecs at the each bandwidth to provide
the best possible sound quality for the specific content type.

o Stereo Sound - This is the first time any company has offered stereo sound for 28.8 Kbps
modems. In addition, near CD quality sound can be delivered for ISDN and LAN connections.

o Robust UDP - Improves sound quality by improving communication between RealAudio Player
and RealAudio Server.

o Java-enabled Plug-in - The Java-enabled Plug-in provides access to RealAudio programming
within Java environments and extends the audio capabilities of your browser.

o HTTP Streaming - Allows casual audio content providers to stream RealAudio sound. While this

method is not as robust, it provides a reasonable method for providing RealAudio content.



RealAudio Players Components

In addition to the RealAudio Player 3.0 beta, three different special-purpose RealAudio
Player components are installed on your computer. The components work with different
elements within World Wide Web pages to deliver RealAudio sound in a variety of ways.
The RealAudio Player components are:

RealAudio Plug-in

RealAudio Control
for ActiveX

RealAudio Xtra for
Shockwave

Java-enabled Plug-
in

The Plug-in provides access to RealAudio
programming and extends the audio capabilities
of your Netscape browser (Netscape Navigator 2.0
or later).

The Control provides access to RealAudio
programming and extends the audio capabilities
of your Internet Explorer 3.0 browser and Visual
Basic applications.

The RealAudio Xtra for Shockwave provides
RealAudio programming within a Macromedia
Shockwave movie.

The Java-enabled Plug-in provides access to
RealAudio programming within Java environments
and extends the audio capabilities of your
browser.

Overview of the RealAudio Player 3.0 beta

The RealAudio Player 3.0 beta enables you to listen to RealAudio files over the Internet or
over a local area network in real-time, without downloading the sound clip to your hard
drive. When you click on a RealAudio link from a World Wide Web page, your RealAudio
Player 3.0 beta automatically opens and plays the file you have selected.
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Overview of the RealAudio Player 3.0 beta
Section Description

Play/Pause Button

This button plays or pauses a clip depending
on the status of the clip.



Stop Button

Fast Forward/Rewind
Buttons

Position Slider

Link to the Progressive
Networks Home Page
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Title, Author and
Copyright Text

Volume Control

Status Bar

Stereo Indicator

Elapsed Time

Click the II‘ button to stop the clip.

Click either the A button or the Xl button to
fast forward or rewind the RealAudio clip in 10
second intervals.

The slider moves as a clip is being played. You
can fast forward or rewind to a different
section of the audio clip by dragging the
slider.

If you are connected to the Internet, click this
button to link to the Progressive Networks
Home Page - the Home of RealAudio. The icon
displayed changes depending on the action of
the RealAudio Player 3.0 beta. The following
are the icons that can be displayed and their
meanings:

Indicates that the RealAudio Player 3.0 beta is
contacting a RealAudio Server.

Indicates that the RealAudio Player 3.0 beta is
playing an audio stream.

Indicates moderate packet loss, sound quality
similar to AM radio transmission.

Indicates high packet loss, sound quality
below AM radio transmission (garbled or
choppy speech, skipping).

The Content provider specifies the text in
these fields; they normally describe the clip
being played.

The volume control indicates the volume at
which the clip is being played. You can
increase the volume by dragging the control
up, and decrease the volume by dragging the
control down.

The status bar displays the current action of
the Player. For example: Buffering, Playing
28.8 Network Stream, Or Paused.

This graphic indicates whether the clip
currently being played is mono or stereo.

Stehedl - Indicates that the clip being played is
stereo.

fane _ |ndicates that the clip being played is
mono.

The Elapsed Time is the length of time that
the clip has been playing.



Total Time The Total Time is the length of the entire clip.

Note: When playing a live stream, the Total
Time value is 00:00.0.

See Also:

RealAudio Player 3.0 beta Menus
Using the RealAudio Player 3.0 beta
Troubleshooting




RealAudio Player 3.0 beta Menus

The RealAudio Player 3.0 beta has five menus: File, View, Clip, Sites, and Help. These
menus allow you to take full advantage of the RealAudio Player 3.0 beta features.

See Also:
File Menu

View Menu

Clip Menu
Sites Menu

Help Menu



File Menu

Commands from the File menu allow you to play RealAudio files without using your World
Wide Web browser to find files on the Internet and to exit the RealAudio Player 3.0 beta.

Menu Option Description
Open Location Select this option to play RealAudio files

through the Internet without using your World
Wide Web browser. In the Open Location
dialog, enter the URL (Internet address) of a
.ra or .ram file.

Open File Select this option to play a local RealAudio
file. When the Open File dialog appears,
select a .ra or .ram file stored on your
computer.

Open Recent Select this option to view a list of recently
played clips. You can select a clip from this
list to hear the clip again.

Exit Select this option to exit the RealAudio Player
3.0 beta.

View Menu

Commands from the View menu allow you to control the appearance, to customize the
operation, and view the performance of the RealAudio Player 3.0 beta.

Menu Option Description
Info & Volume Select this option to display the volume

control, and the title, author, and copyright
information for the clip; a check mark
appears next to the option. Select the option
again to hide the information; the check mark
is removed.

Status Bar Select this option to display the Status Bar; a
check mark appears next to the option.
Select the option again to hide the bar; the
check mark is removed.

Refer to Messages for a list of messages that
appear in the Status Bar

Preferences Select this option to display the Preferences
window for configuring the RealAudio Player
3.0 beta. You can set preferences from this
window. Refer to Setting Preferences for more
information.

Statistics Select this option to display the transmission
quality information in the Connection



Statistics dialog. The Connection Statistics
window reports the performance of the
Internet connection between the RealAudio
Server and the RealAudio Player 3.0 beta.

Always on Top Select this option to make the RealAudio
Player 3.0 beta remain on top of all other
windows, even when another window is
active; a check mark appears next to the
option. Always on Top is convenient for
keeping the RealAudio Player 3.0 beta visible
while you interact with your World Wide Web
browser. Select this option again to allow
other windows to open on top of the
RealAudio Player 3.0 beta; the check mark is
removed.

Messages

Buffering - Indicates that the Player has connected with a RealAudio server and is
collecting the audio stream in the buffer (holding area) until enough packets arrive to start
playing the audio stream. This takes only a few seconds.

Stopped - Indicates the audio has stopped, because you selected the stop button or
because the end of the clip has been reached.

Paused - Indicates the audio has stopped because you selected the Pause button.

Playing xx.x local file - Indicates the algorithm with which the local RealAudio file was
encoded.

Playing xx.x network stream - Indicates the algorithm with which the network
RealAudio file was encoded.

Playing xx.x live stream - Indicates the algorithm with which the live RealAudio file is
being encoded.

(Clip 1 of 2) - Indicates that the first clip of a multi-clip stream is being played.

Contacting Host - Indicates that the Player is requesting a file from a RealAudio Server.






Clip Menu

Some RealAudio clips are several files played one after the other. Commands from the Clip
menu allow you to move between clips in a multi-clip RealAudio (.ram) file. They are
similar to the seek buttons on a CD player. If there is only one RealAudio clip at the link
you are accessing, these options are not available.

Previous Clip and Next Clip are also available from the shortcut menu that appears when
you right-click the mouse button in the RealAudio Player 3.0 beta window.

Menu Option Description

Previous Clip Select this option to play the previous clip in
a multi-clip RealAudio (.ram) file.

Next Clip Select this option to play the next clip in a
multi-clip RealAudio (.ram) file.

Sites Menu

Commands from the Site menu allow you to access various pages at the Progressive
Networks and Timecast World Wide Web sites. This feature works with popular World Wide
Web browsers including Netscape Navigator, Internet Explorer, Mosaic, Spyglass Mosaic,
and Spry Mosaic. If you are connected to the Internet, and your World Wide Web browser is
not open, the RealAudio Player 3.0 beta opens it for you.

Note: You must be connected to the Internet in order to reach these sites.

Menu Option Description

RealAudio Home Page Select this option to access the Progressive
Networks Home Page.

Timecast: The Select this option to access Timecast: the

RealAudio Guide RealAudio Guide. Timecast contains a list of
World Wide Web sites providing RealAudio
content.

RealAudio Help Page Select this option to access the RealAudio

main help page.

Help Menu

Commands from the Help menu provide you with online help and information about the
RealAudio Player 3.0 beta.

The latest support and technical information is available at:
http://www.realaudio.com/help.html

Please refer to the enclosed Technical Support Card for more information on contacting



Progressive Networks Technical Support.

Menu Option Description

Contents Select this option to open the online help for
the RealAudio Player 3.0 beta.

About Select this option to display the RealAudio
Player 3.0 beta version and Copyright
information.

Using the RealAudio Player 3.0 beta

The RealAudio Player 3.0 beta enables you to click on a RealAudio link from your Web
browser and begin playing audio instantly, without download delays. In addition, you can
pause, rewind, fast-forward, stop, and start the audio at a click of a button.

See Also:
Starting a Clip

Pausing a Clip
Stopping a Clip




’@ Starting a Clip
There are several ways to start a RealAudio clip:

e Click a RealAudio link on a World Wide Web page. Your World Wide Web browser opens the
RealAudio Player 3.0 beta and the audio is streamed to the RealAudio Player 3.0 beta
immediately. After storing a few seconds of audio (buffering), the clip begins.

e Access a World Wide Web site or select an action that automatically plays a clip. Your World
Wide Web browser opens the RealAudio Player 3.0 beta and the audio is streamed to the
RealAudio Player 3.0 beta immediately. After storing a few seconds of audio (buffering), the clip
begins.

e Select Open File or Open Location from the File menu on the RealAudio Player 3.0 beta. For
more information, refer to File Menu.

See Also:

Pausing a Clip
Stopping a Clip



Pausing a Clip

You can pause a clip while it is playing by clicking the £ | button. This halts the
audio stream. If you want to resume the clip at the same point it was paused, click the

button.

If you pause a clip but do not resume playing after several minutes, the RealAudio Server
may terminate your connection. The length of time you can pause a clip without your
connection terminating depends on the particular RealAudio Server.

See Also:

Starting a Clip
Stopping a Clip



Stopping a Clip

You can stop a clip while it is playing by clicking the .a button. The clip stops playing. To
play the clip again from the beginning, click the

button.
See Also:

Starting a Clip
Pausing a Clip



Setting Preferences

You can customize the RealAudio Player 3.0 beta by changing the settings in the
Preferences window. The Preferences control various aspects of the RealAudio Player 3.0
beta functionality such as the number of clips to remember, network information, and
proxy information.

See Also:

General Preferences

Network Preferences

Proxy Preferences

Advanced Preferences

Language Preferences




General Preferences

The General tab in the Preferences window contains preferences for clip memory,
Synchronized Multimedia support, and CPU usage.

Field

Remember the [ ] Most
Recent Clips

Synchronized
Multimedia

Audio Quality versus
CPU Usage

Description

Enter the number of clips that you want the
RealAudio Player 3.0 beta to remember and
display when using the Open Recent option
from the File menu.

Click this box to enable Synchronized
Multimedia; a check mark appears in the box.
When this option is enabled, the RealAudio
Player 3.0 beta can trigger new World Wide
Web pages during a RealAudio Synchronized
Multimedia clip, thus providing a narrated slide
show.

You can disable this option by clicking the field
again; the check mark is removed. When this
option is disabled, the RealAudio Player 3.0
beta is unable to display visual content in
Synchronized Multimedia sound clips.

You can move the slider to control the Audio
Quality versus CPU Usage. To achieve the best
sound quality from the RealAudio 28.8
algorithm, your computer needs to quickly
process a large quantity of Internet data. If
your machine experiences a decrease in
performance while playing a RealAudio file,
slide this bar to change this setting. You will
need to experiment to discover the best
setting for your machine and Internet
connection.

Network Preferences

The Network tab in the Preferences window allows you to customize your network
connection for the RealAudio Player 3.0 beta.

The descriptions of these preferences assume a basic knowledge of Internet protocols and
firewalls. For more information about firewalls, refer to our World Wide Web site at
http://www.realaudio.com/firewall.html.

Field
Receive Audio Via

Description

Select UDP (User Datagram Protocol) or TCP
(Transmission Control Protocol) as the method
for receiving audio. By default, the RealAudio



Player 3.0 beta receives data packets using
UDP. If you cannot receive UDP packets
because you are behind a packet-filtering
firewall, set this preference to TCP.

Note: If you use TCP with a modem, you may
experience gaps in the audio stream.

Use Specified Port Click this field if you want to configure the
packet-filtering firewalls to receive UDP
through one specified port. Enter the port
number. The RealAudio Player 3.0 beta can
receive UDP packets through any designated
port between 1000 and 9999. Your firewall
administrator should tell you what port to
specify.

Note: RealAudio TCP packets are only
received through Port 7070.

Server Timeout Enter the maximum number of seconds the
RealAudio Player 3.0 beta should wait to
connect to a RealAudio Server. If it does not
connect within the specified time period, a
Retry/Cancel message is displayed. A value of
0 means that the RealAudio Player 3.0 beta
never times out.

Send Statistics Click this field if you want the RealAudio Player
3.0 beta to send connection quality statistics
to the RealAudio Server after playing a clip.

This feature helps connection providers assure
transmission quality. This information is
basically what you see in the Connection
Statistics dialog and includes the number of
packets received, lost in transmission, arrived
late, arrived early, and arrived out of order.

Note: The RealAudio Player 3.0 beta does not
access or send the Server any information
about your identity (your user name or e-mail
address).

Loss Correction Click this field if you want the RealAudio Player
3.0 beta to compensate for packets lost in
transmission between the RealAudio Server
and your RealAudio Player 3.0 beta. You may
hear a momentary warble in the audio stream
if packets are missing.

When Loss Correction is unchecked, the lost
packets are dropped, causing a skip.

Proxy Preferences



A proxy is a server that acts as an intermediary between a company's protected LAN and
the Internet. For more information about proxies and firewalls, read
http://www.realaudio.com/firewall.html. The proxy server insures that all data
transmission between the Internet and a user on the LAN is authorized. The RealAudio
Player 3.0 beta can be configured to work with proxy servers by setting the proxy
preferences. If you set the Proxy preferences, you must enter a RealAudio Proxy and a
HTTP Proxy.

Field Description

Use Proxy Click this box if the RealAudio Player 3.0 beta
should connect to the Server using a proxy; a
check mark appears in the field. Otherwise, do
not click this box.

Note: If you are behind a firewall and do not
know the host name or port number of your
proxy server, ask your firewall administrator.

RealAudio Proxy Enter the domain name or IP address of the
RealAudio proxy server and port number that
the RealAudio Player 3.0 beta should use to
communicate with the proxy server and
stream the audio.

Note: For information on RealAudio Proxy,
read
http://www.realaudio.com/firewall.html

HTTP Proxy Enter the domain name or IP address of the
HTTP proxy server and port number that the
RealAudio Player 3.0 beta should use to
communicate with the proxy server and the
World Wide Web server. This should be set to
the same port as your browser, check your
World Wide Web browsers proxy configuration.

No Proxy for: [Host 1, If you have specified that the RealAudio Player

Host2...] 3.0 beta should be connected to the Server
using a proxy, you can specify certain local
hosts (domain names or IP Addresses) with
which you do not need to communicate using
the proxy server. Enter these hosts in this
field. This field is only available if you have
enabled the Use Proxy option.

Your firewall administrator can provide you
with this information, if appropriate.

Advanced Preferences

Options on the Advanced tab of the Preferences window override the RealAudio Player 3.0
beta defaults for sound card compatibility. You dont need these options unless you are
having troubles with sound quality.



Field Description

Disable 16-bit sound Click this field if you want to force your sound

(use 8-bit only) card to play only 8-bit sound; a check mark
appears. Use this option only if there is
evidence of compatibility problems with your
sound card. The RealAudio Player 3.0 beta
normally delivers 16-bit audio to the sound
card. The RealAudio Player 3.0 beta should
automatically detect if the sound card only
supports 8-bit audio, and then deliver 8-bit
audio.

Disable custom sampling Click this field if you want to force your sound

rates card to play only 11 kHz sound; a check mark
appears. Use this option only if there is
evidence of compatibility problems with your
sound card, for example clips play at the
wrong speed or sound scratchy or distorted.
The RealAudio Player 3.0 beta normally
delivers 8 kHz audio to the sound card. If your
sound card does not support the 8 kHz
sampling rate, the audio may sound high-
pitched or too fast. When this option is
selected, the RealAudio Player 3.0 beta
changes audio to 11 kHz before delivering it to
the sound card. This option increases CPU
usage slightly.

Language Preferences

The setting on the Language tab of the Preferences window determines the language used
within the RealAudio Player 3.0 beta.

Field Description

Current Language This field displays the language being used
within the RealAudio Player 3.0 beta

Installed Languages Select the language you want to use within the
RealAudio Player 3.0 beta menus and
windows.

Note: Please contact Progressive Networks
regarding information on languages available
for the RealAudio Player 3.0 beta.

Troubleshooting

For the latest information on RealAudio products, visit the Progressive Networks home
page at:



http://www.realaudio.com

A technical knowledge base, frequently asked questions list and technical library are
available from our web site at:

http://www.realaudio.com/help.html

Please refer to your Technical Support Card for more information on contacting Progressive
Networks Technical Support.

See Also:

How do | configure my browser to support RealAudio?

What's wrong when the sound is poor?

Why doesn't my RealAudio Player 3.0 beta have a Volume Control slider?

What causes RealAudio clips to occasionally skip?

Why can't | play RealAudio clips on my computer at work?




’@ How do | configure my browser to support RealAudio?
With most browsers, the RealAudio Player 3.0 beta installation configures the browser to
support RealAudio. If you change your browser and it stops recognizing RealAudio files,
reinstall the RealAudio Player 3.0 beta. To manually configure your World Wide Web
browser, do the following:

1. Open the Options or Preferences or Settings menu.
2. Select the Helper Applications or similar option.
3. Look for "audio/x-pn-realaudio” in the File type list. If an entry exists, select the entry.

Otherwise, click New Type. Enter audio as the Mime Type. Enter xpnrealaudio as
the Mime SubType. Click OK.

4. Enter ra,ram in the Extensions field.

5. Select the Launch Application option. Browse and find the directory in which the
RealAudio Player 3.0 beta is installed.

6. Select RealAudio (raplayer.exe) as the application to launch.



What's wrong when the sound is poor?

The sound quality should be similar to FM mono. If the sound quality is below AM radio
transmission (garbled or choppy speech, skipping, etc.), use the following to isolate and
correct the problem. If the audio quality was poor when the "Setup is Complete" file was
played (during the RealAudio Player 3.0 beta installation), try configuring the RealAudio
Player 3.0 beta or your sound card.

If the audio quality was poor from a particular site, use the Connection Statistics window in
the RealAudio Player 3.0 beta to check for lost packets. If the packet loss is high, it may be
due to a busy network. Connect to the site at a later time.

If the audio quality is poor on every site, do the following:

1. Check the actual modem connection speed. This may be shown in the lighted display
for external modems, or through an information window if you have an internal
modem (check the user manual for your modem). Sometimes service providers use a
lower rate connection speed such as 14.4, so even though you are dialing in on a
28.8 modem, you are only receiving data at 14.4 Kbps.

2. For a 14.4 connection on an Apple Duo, go to the modem properties window and turn
off the compression control. Compression uses CPU cycles that the RealAudio Player
3.0 beta may need. Since RealAudio files are already compressed, this utility is not
necessary. Turning off compression will not affect your computer's other operations.

3. If you are using an external modem with a Windows PC and the Connections Statistics
window shows minimal packet loss (10% or less), there may be a problem with the
speed at which packets are transferred between the modem and serial card. Try
setting the port speed higher (at least twice the modem speed).



Why doesn't my RealAudio Player 3.0 beta have a Volume

Control slider?
Be sure a check mark appears next to the Info & Volume command on the View menu. If
the check mark does not appear, select Info & Volume from the View menu.

If the sound card installed in your computer does not support volume control, the Volume
Control slider does not appear on the RealAudio Player 3.0 beta.



What causes RealAudio clips to occasionally skip?

There are two possible reasons:

e  Starting or quitting large applications while playing RealAudio can cause a brief disruption of the
playback.

¢ When you use PerfectPlay mode with a live stream, occasional gaps in the audio will occur when
your RealAudio Player 3.0 beta skips to keep up with the network.



Why can't | play RealAudio clips on my computer at
work?

If you're on a local area network which is attached to the Internet, and are unable to play
RealAudio files from remote Web sites, it's possible that your company's firewall is
preventing the RealAudio stream from reaching you. Users can receive live and on-demand
audio from the Internet without exposing their company's network to security risks.

If your computer is behind a firewall, please see Progressive Networks firewall page for
more information: http://www.realaudio.com/firewall.html



Play/Pause Button

This button plays or pauses a clip depending on the status of the clip.



Stop Button
Click the button to stop the clip.



Fast Forward/Rewind Buttons

Click either the .a button or the

.a button to fast forward or rewind the RealAudio clip in 10 second intervals.



Position Slider

The slider moves as a clip is being played. You can fast forward or rewind to a different
section of the audio clip by dragging the slider.



Link to the Progressive Networks Home Page

If you are connected to the Internet, click this button to link to the Progressive Networks
Home Page - the Home of RealAudio. The icon displayed changes depending on the action
of the RealAudio Player 3.0 beta.



Volume Control

The volume control indicates the volume at which the clip is being played. You can
increase the volume by dragging the control up, and decrease the volume by dragging the
control down.



Status Bar

The status bar displays the current action of the RealAudio Player 3.0 beta. For example:
Buffering, Playing 28.8 Network Stream, Or Paused.



Stereo Indicator

This graphic indicates whether the clip currently being played is mono or stereo.

.:a - Indicates that the clip being played is stereo.

’:a - Indicates that the clip being played is mono.



Elapsed Time/Total Time

The Elapsed Time is the length of time that the clip has been playing. The Total Time is the
length of the entire clip.

Note: When playing a live stream, the Total Time value is 00.00.0.



Title, Author and Copyright Text

The content provider specifies the text in these fields; they normally describe the clip
being played.



File

Commands from the File menu allow you to play RealAudio files without using your Web
browser to find files on the Internet and to exit the RealAudio Player 3.0 beta.



View

Commands from the View menu allow you to control the appearance, to customize the
operation, and view the performance of the RealAudio Player 3.0 beta.



Clip

Commands from the Clip menu allow you to move between clips in a multi-clip RealAudio
(.ram) file. They are similar to the seek buttons on a CD player. If there is only one
RealAudio clip at the link you are accessing, these options are not available.

Previous Clip and Next Clip are also available from the shortcut menu that appears when
you click the right mouse button anywhere in the RealAudio Player 3.0 beta window.



Sites

Commands from the Site menu allow you to access various pages at the Progressive
Networks and Timecast World Wide Web sites. This feature works with popular World Wide
Web browsers including Netscape, Internet Explorer, Mosaic, Spyglass Mosaic, and Spry
Mosaic. If you are connected to the Internet, and your World Wide Web browser is not
open, the RealAudio Player 3.0 beta opens it for you.

Note: You must be connected to the Internet in order to reach these sites.



Help

Commands from the Help menu provide you with online help and information about the
RealAudio Player 3.0 beta.






